Sep 26 2016
Apple iCloud Windows Software Updater v6.0
 

iCloud for Windows v6.0

This update improves the stability, compatibility, and security of iCloud for Windows, and is recommended for all users.

iCloud for Windows v6.0 requires:

  • Microsoft Windows 7 or later
  • Outlook 2007 or later or iCloud.com (for Mail, Contacts, Calendars). This version includes support for Microsoft Outlook on Windows 10.
  • Internet Explorer 10 or later, Firefox 30 or later, or Google Chrome 28 or later (for Bookmarks)

See iCloud system requirements for additional detail.

For more information on the security content of this update see https://support.apple.com/kb/HT201222.

Share

Written by

View all posts by:

Categories: Uncategorized